use strict;
my $str = '$(".delete_package").live("click", function() {
// this is a test
}
$(".add_package").live( "mouseout", function(e) {
// this is a test
}
$( ".ccc_package" ).live( "mouseover", function(e, x) {
// this is a with var e + x
}
';
my $regex = qr/\$\(\s*?["']([^"']+?)["']\s*?\)\.live\(\s*?["']([^"']+?)["'][^\(]+?\(/p;
my $subst = '$(document.body).on("$2", "$1", function(';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";