using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['""][^'""]*['""]\s*)?)+>";
string input = @"<p data=""_data"" name=""someName"" style=""border: 1px solid black"" foo=""bar"" id=""someId"" foo=""bar"" class=""someClass"" foo=""bar"">kjasdkfja;lsdkf</p>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}