$re = '/<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=[\'"][^\'"]*[\'"]\s*)?)+>/';
$str = '<p data="_data" name="someName" style="border: 1px solid black" foo="bar" id="someId" foo="bar" class="someClass" foo="bar">kjasdkfja;lsdkf</p>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);