import Foundation
let pattern = #"<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['"][^'"]*['"]\s*)?)+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p data="_data" name="someName" style="border: 1px solid black" foo="bar" id="someId" foo="bar" class="someClass" foo="bar">kjasdkfja;lsdkf</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}