import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+)\\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['\"][^'\"]*['\"]\\s*)?)+>";
final String string = "<p data=\"_data\" name=\"someName\" style=\"border: 1px solid black\" foo=\"bar\" id=\"someId\" foo=\"bar\" class=\"someClass\" foo=\"bar\">kjasdkfja;lsdkf</p>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}