const regex = /<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['"][^'"]*['"]\s*)?)+>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)\\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=[\'"][^\'"]*[\'"]\\s*)?)+>', '')
const str = `<p data="_data" name="someName" style="border: 1px solid black" foo="bar" id="someId" foo="bar" class="someClass" foo="bar">kjasdkfja;lsdkf</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}