#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[0-9]{1,5}$)|(^[0-9]{1,5}(\,|\.)[0-9]{1,2}$)"
Local $sString = "5" & @CRLF & _
"5,47" & @CRLF & _
"10.5" & @CRLF & _
"100" & @CRLF & _
"10000" & @CRLF & _
"52,90" & @CRLF & _
"5.8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")