import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[0-9]{1,5}$)|(^[0-9]{1,5}(\\,|\\.)[0-9]{1,2}$)";
final String string = "5\n"
+ "5,47\n"
+ "10.5\n"
+ "100\n"
+ "10000\n"
+ "52,90\n"
+ "5.8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}