package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[0-9]{1,5}$)|(^[0-9]{1,5}(\,|\.)[0-9]{1,2}$)`)
var str = `5
5,47
10.5
100
10000
52,90
5.8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}