// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[0-9]{1,5}$)|(^[0-9]{1,5}(\,|\.)[0-9]{1,2}$)").unwrap();
let string = "5
5,47
10.5
100
10000
52,90
5.8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}