using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[0-9]{1,5}$)|(^[0-9]{1,5}(\,|\.)[0-9]{1,2}$)";
string input = @"5
5,47
10.5
100
10000
52,90
5.8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}