#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<right>([^<\/>]*)<\/>?"
Local $sString = "<right>Phí tex5,000円</>" & @CRLF & _
"<right>Phítext5,000円" & @CRLF & _
"<right>" & @CRLF & _
"Phítext5,000円" & @CRLF & _
"</>" & @CRLF & _
"<right>" & @CRLF & _
"Phítext5,000円</>" & @CRLF & _
"<right>" & @CRLF & _
"<right>" & @CRLF & _
"hello" & @CRLF & _
"</>" & @CRLF & _
"</>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")