package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<right>([^<\/>]*)<\/>?`)
var str = `<right>Phí tex5,000円</>
<right>Phítext5,000円
<right>
Phítext5,000円
</>
<right>
Phítext5,000円</>
<right>
<right>
hello
</>
</>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}