$re = '/<right>([^<\/>]*)<\/>?/';
$str = '<right>Phí tex5,000円</>
<right>Phítext5,000円
<right>
Phítext5,000円
</>
<right>
Phítext5,000円</>
<right>
<right>
hello
</>
</>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);