re = /<right>([^<\/>]*)<\/>?/
str = '<right>Phí tex5,000円</>
<right>Phítext5,000円
<right>
Phítext5,000円
</>
<right>
Phítext5,000円</>
<right>
<right>
hello
</>
</>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end