using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^Name\R(.+)\REmail\R(.+)\RPhone Number\R(.+)\RInquiry or Message\R(?s)(.+)";
        string input = @"Name
Troy LastName
Email
troytesting3@gmail.com
Phone Number
914 361-9012
Inquiry or Message
message as a test
to process";
        RegexOptions options = RegexOptions.CultureInvariant;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}