import re
regex = re.compile(r"^Name\R(.+)\REmail\R(.+)\RPhone Number\R(.+)\RInquiry or Message\R(?s)(.+)", flags=re.UNICODE)
test_str = ("Name\n"
"Troy LastName\n"
"Email\n"
"troytesting3@gmail.com\n"
"Phone Number\n"
"914 361-9012\n"
"Inquiry or Message\n"
"message as a test\n"
"to process")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")