// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)^Name\R(.+)\REmail\R(.+)\RPhone Number\R(.+)\RInquiry or Message\R(?s)(.+)").unwrap();
let string = "Name
Troy LastName
Email
troytesting3@gmail.com
Phone Number
914 361-9012
Inquiry or Message
message as a test
to process";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}