#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\.[a-z]{2,24}$"
Local $sString = "alessio" & @CRLF & _
"alessio@michelini.dev" & @CRLF & _
"alessio23@michelini" & @CRLF & _
"alessio-1@michelini." & @CRLF & _
"alessio+t123@michelini.dev" & @CRLF & _
"el_barto@test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")