import re
regex = re.compile(r"^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\.[a-z]{2,24}$", flags=re.MULTILINE)
test_str = ("alessio\n"
"alessio@michelini.dev\n"
"alessio23@michelini\n"
"alessio-1@michelini.\n"
"alessio+t123@michelini.dev\n"
"el_barto@test.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")