re = /^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\.[a-z]{2,24}$/m
str = 'alessio
alessio@michelini.dev
alessio23@michelini
alessio-1@michelini.
alessio+t123@michelini.dev
el_barto@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end