const regex = /^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\.[a-z]{2,24}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\\.[a-z]{2,24}$', 'gm')
const str = `alessio
alessio@michelini.dev
alessio23@michelini
alessio-1@michelini.
alessio+t123@michelini.dev
el_barto@test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}