import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9+-_])+@([a-zA-Z0-9-]+)\\.[a-z]{2,24}$";
final String string = "alessio\n"
+ "alessio@michelini.dev\n"
+ "alessio23@michelini\n"
+ "alessio-1@michelini.\n"
+ "alessio+t123@michelini.dev\n"
+ "el_barto@test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}