# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s\d+-[A-Z]+//g;t' <<< "Есть строки такого содержания:
some text 278094-A, some text 278094-FG, some text 6508-N, some text
Нужно удалить конструкции с цифрами и буквами через дефис, т.е. чтобы стало так:
some text, some text, some text, some text
"