$re = '/\s\d+-[A-Z]+/';
$str = 'Есть строки такого содержания:
some text 278094-A, some text 278094-FG, some text 6508-N, some text
Нужно удалить конструкции с цифрами и буквами через дефис, т.е. чтобы стало так:
some text, some text, some text, some text
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;