const regex = /\s\d+-[A-Z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\d+-[A-Z]+', 'g')
const str = `Есть строки такого содержания:
some text 278094-A, some text 278094-FG, some text 6508-N, some text
Нужно удалить конструкции с цифрами и буквами через дефис, т.е. чтобы стало так:
some text, some text, some text, some text
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);