// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s\d+-[A-Z]+").unwrap();
let string = "Есть строки такого содержания:
some text 278094-A, some text 278094-FG, some text 6508-N, some text
Нужно удалить конструкции с цифрами и буквами через дефис, т.е. чтобы стало так:
some text, some text, some text, some text
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}