#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)match ([^\s=]+) = ([^;]+); // MATCH"
Local $sString = "some random strings that are not 'hstep' form" & @CRLF & _
"... " & @CRLF & _
"match hstep1_num00 = {eau,t,nb,v,d}; // MATCH" & @CRLF & _
"match hstep1_num01 = {c,bul,kv,e}; // MATCH" & @CRLF & _
"... " & @CRLF & _
"match hstep3_num00 = {u_ku,b,ntv,q}; // MATCH" & @CRLF & _
"match hstep3_num01 = {qq,rask,cb_p}; // MATCH" & @CRLF & _
"match hstep3_num02 = {c,a,ha,w,ykl}; // MATCH" & @CRLF & _
"match hstep3_num03 = {p,gu,enb_q_b,z,d}; // MATCH" & @CRLF & _
"..." & @CRLF & _
"some random strings that are not 'hstep' form" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")