re = /match ([^\s=]+) = ([^;]+); \/\/ MATCH/m
str = 'some random strings that are not \'hstep\' form
...
match hstep1_num00 = {eau,t,nb,v,d}; // MATCH
match hstep1_num01 = {c,bul,kv,e}; // MATCH
...
match hstep3_num00 = {u_ku,b,ntv,q}; // MATCH
match hstep3_num01 = {qq,rask,cb_p}; // MATCH
match hstep3_num02 = {c,a,ha,w,ykl}; // MATCH
match hstep3_num03 = {p,gu,enb_q_b,z,d}; // MATCH
...
some random strings that are not \'hstep\' form
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end