import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "match ([^\\s=]+) = ([^;]+); // MATCH";
final String string = "some random strings that are not 'hstep' form\n"
+ "... \n"
+ "match hstep1_num00 = {eau,t,nb,v,d}; // MATCH\n"
+ "match hstep1_num01 = {c,bul,kv,e}; // MATCH\n"
+ "... \n"
+ "match hstep3_num00 = {u_ku,b,ntv,q}; // MATCH\n"
+ "match hstep3_num01 = {qq,rask,cb_p}; // MATCH\n"
+ "match hstep3_num02 = {c,a,ha,w,ykl}; // MATCH\n"
+ "match hstep3_num03 = {p,gu,enb_q_b,z,d}; // MATCH\n"
+ "...\n"
+ "some random strings that are not 'hstep' form\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}