# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"match ([^\s=]+) = ([^;]+); // MATCH"
test_str = ("some random strings that are not 'hstep' form\n"
"... \n"
"match hstep1_num00 = {eau,t,nb,v,d}; // MATCH\n"
"match hstep1_num01 = {c,bul,kv,e}; // MATCH\n"
"... \n"
"match hstep3_num00 = {u_ku,b,ntv,q}; // MATCH\n"
"match hstep3_num01 = {qq,rask,cb_p}; // MATCH\n"
"match hstep3_num02 = {c,a,ha,w,ykl}; // MATCH\n"
"match hstep3_num03 = {p,gu,enb_q_b,z,d}; // MATCH\n"
"...\n"
"some random strings that are not 'hstep' form\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.