package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)match ([^\s=]+) = ([^;]+); // MATCH`)
var str = `some random strings that are not 'hstep' form
...
match hstep1_num00 = {eau,t,nb,v,d}; // MATCH
match hstep1_num01 = {c,bul,kv,e}; // MATCH
...
match hstep3_num00 = {u_ku,b,ntv,q}; // MATCH
match hstep3_num01 = {qq,rask,cb_p}; // MATCH
match hstep3_num02 = {c,a,ha,w,ykl}; // MATCH
match hstep3_num03 = {p,gu,enb_q_b,z,d}; // MATCH
...
some random strings that are not 'hstep' form
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}