#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"_id" : "CollectiveAgreement:(?!8|12|19|20|88|109)(\d).*?""
Local $sString = "{" & @CRLF & _
" "_index" : "documents-prod"," & @CRLF & _
" "_type" : "_doc"," & @CRLF & _
" "_id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620"," & @CRLF & _
" "_score" : 0.0," & @CRLF & _
" "_source" : {" & @CRLF & _
" "id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620"," & @CRLF & _
" "type" : "CollectiveAgreement"," & @CRLF & _
" "title" : "Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)"," & @CRLF & _
" "text" : "Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas."," & @CRLF & _
" "path" : "/agreements/19/documents/17#mod-4498813045"," & @CRLF & _
" "memberOrganizationFamilyIds" : [ ]," & @CRLF & _
" "collectiveAgreementMerkuriusIds" : [" & @CRLF & _
" "a0ce80f7-ff07-de11-b4e1-02bf9e69ca65"" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")