using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""_id"" : ""CollectiveAgreement:(?!8|12|19|20|88|109)(\d).*?""";
string input = @"{
""_index"" : ""documents-prod"",
""_type"" : ""_doc"",
""_id"" : ""CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620"",
""_score"" : 0.0,
""_source"" : {
""id"" : ""CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620"",
""type"" : ""CollectiveAgreement"",
""title"" : ""Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)"",
""text"" : ""Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas."",
""path"" : ""/agreements/19/documents/17#mod-4498813045"",
""memberOrganizationFamilyIds"" : [ ],
""collectiveAgreementMerkuriusIds"" : [
""a0ce80f7-ff07-de11-b4e1-02bf9e69ca65""
]
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}