# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d\d)\\/(\d\d)\\/(\d\d\d\d)//gm;t' <<< "11/16/1954"