use strict;
my $str = '11/16/1954';
my $regex = qr/(\d\d)\/(\d\d)\/(\d\d\d\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";