# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G\p{Lu}+\K[.\h]+(?!\p{Lu}\p{Ll})//gm;t' <<< "J.J. Scott"