const regex = /\G\p{Lu}+\K[.\h]+(?!\p{Lu}\p{Ll})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G\\p{Lu}+\\K[.\\h]+(?!\\p{Lu}\\p{Ll})', 'gm')
const str = `J.J. Scott`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);