$re = '/\G\p{Lu}+\K[.\h]+(?!\p{Lu}\p{Ll})/m';
$str = 'J.J. Scott';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;