using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G\p{Lu}+\K[.\h]+(?!\p{Lu}\p{Ll})";
string substitution = @"";
string input = @"J.J. Scott";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}