use strict;
my $str = 'J.J. Scott';
my $regex = qr/\G\p{Lu}+\K[.\h]+(?!\p{Lu}\p{Ll})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";