#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![+])(\d*\.?\d+)(?![%+])(?=\D|$)"
Local $sString = "4.31 m x 2 m x 3.222 m" & @CRLF & _
"220m" & @CRLF & _
"'St 473m" & @CRLF & _
"rangeZng 2x250m" & @CRLF & _
"Original 250ml 2s 35%" & @CRLF & _
"Qstd 550ml 1+1" & @CRLF & _
"very good cream 250ml 2s 35%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")