$re = '/(?<![+])(\d*\.?\d+)(?![%+])(?=\D|$)/m';
$str = '4.31 m x 2 m x 3.222 m
220m
\'St 473m
rangeZng 2x250m
Original 250ml 2s 35%
Qstd 550ml 1+1
very good cream 250ml 2s 35%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);