using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![+])(\d*\.?\d+)(?![%+])(?=\D|$)";
string input = @"4.31 m x 2 m x 3.222 m
220m
'St 473m
rangeZng 2x250m
Original 250ml 2s 35%
Qstd 550ml 1+1
very good cream 250ml 2s 35%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}