import re
regex = re.compile(r"(?<![+])(\d*\.?\d+)(?![%+])(?=\D|$)", flags=re.MULTILINE)
test_str = ("4.31 m x 2 m x 3.222 m\n"
"220m\n"
"'St 473m\n"
"rangeZng 2x250m\n"
"Original 250ml 2s 35%\n"
"Qstd 550ml 1+1\n"
"very good cream 250ml 2s 35%")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")