use strict;
my $str = '4.31 m x 2 m x 3.222 m
220m
\'St 473m
rangeZng 2x250m
Original 250ml 2s 35%
Qstd 550ml 1+1
very good cream 250ml 2s 35%';
my $regex = qr/(?<![+])(\d*\.?\d+)(?![%+])(?=\D|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}