#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\(((?>[^()]+|(?1))*)\))|\G(?!^)(?:\s*(\w+)\s*)(?=\())"
Local $sString = "((weight gt 10) OR (weight lt 100)) AND (length lt 50)" & @CRLF & _
"" & @CRLF & _
"(length lt 50) AND ((weight gt 10) OR (weight lt 100))" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"((weight gt 10) OR (weight lt 100)) AND (length lt 50) AND (length lt 50)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")