const regex = /(?:(\(((?>[^()]+|(?1))*)\))|\G(?!^)(?:\s*(\w+)\s*)(?=\())/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\(((?>[^()]+|(?1))*)\\))|\\G(?!^)(?:\\s*(\\w+)\\s*)(?=\\())', 'gm')
const str = `((weight gt 10) OR (weight lt 100)) AND (length lt 50)
(length lt 50) AND ((weight gt 10) OR (weight lt 100))
((weight gt 10) OR (weight lt 100)) AND (length lt 50) AND (length lt 50)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}