$re = '/(?:(\(((?>[^()]+|(?1))*)\))|\G(?!^)(?:\s*(\w+)\s*)(?=\())/m';
$str = '((weight gt 10) OR (weight lt 100)) AND (length lt 50)
(length lt 50) AND ((weight gt 10) OR (weight lt 100))
((weight gt 10) OR (weight lt 100)) AND (length lt 50) AND (length lt 50)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);