import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\(((?>[^()]+|(?1))*)\\))|\\G(?!^)(?:\\s*(\\w+)\\s*)(?=\\())";
final String string = "((weight gt 10) OR (weight lt 100)) AND (length lt 50)\n\n"
+ "(length lt 50) AND ((weight gt 10) OR (weight lt 100))\n\n\n"
+ "((weight gt 10) OR (weight lt 100)) AND (length lt 50) AND (length lt 50)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}